How to make Wpsubscribers plugin works with OptimizePress theme

In some old version of OptimizePress theme, my plugin can't work because OptimizePress theme using jQuery 1.3.2, it's an old version of jQuery. In this tutorial, I'll show you how to make Wpsubscribers plugin works with OptimizePress theme.

Step 1: Login to your WP admin area and then go to Appearance / Editor menu:

Step 2: Choose OptimizePress theme and then select function.php file to edit:

Step 3: Find these lines of code in the function.php file ( depending on the version of OptimizePress, you may need to add the lines :

if( !is_admin()){
wp_deregister_script('jquery');
wp_register_script('jquery', ("http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js"), false, '1.3.2');
wp_enqueue_script('jquery');
}

and replace  with: ( or adapt the lines to have )
if( !is_admin()){
wp_deregister_script('jquery');
wp_register_script('jquery', ("http://ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js"), false, '1.11.1');
wp_enqueue_script('jquery');
}

(Change 1.3.2 to 1.11.1)

Now your theme is working with Wpsubscribers plugin 🙂






Comments are closed.